Docker Community Forums

Share and learn in the Docker community.

Private Registry


(Lee5i3) #1

Has anyone figured out how to use a private registry?

I’m currently using Gitlabs which has its own docker registry, but have not been able to use docker cloud with it.
I’ve tried using the old version of docker cloud that has an option to add 3rd party repository, but did not work.


(Vadim) #2

There are also some alternative private Docker Registries that you can use. The private-docker-registry.com has for example LDAP/AD/OAuth integration and unlimited repositories on top.


(Jmiraglia) #3

I’m also having an issue using GitLab as 3rd party registry. Everything seems to work ok when importing the repository. It shows up under ‘Repositories’ section in Docker Cloud and I am able to select the repository to see list of tags, however, clicking on the ‘Tags’ tab at the top produces no results (just loading animation over and over). Console indicates a 503 (Service Unavailable) error loading https://cloud.docker.com/api/repo/v1/NAMESPACE/inspect/REGISTRY_DOMAIN/v2/NAMESPACE/IMAGE/tags/list/?page_size=10. Same error when trying to launch service from Docker Cloud interface.

Any help on getting this to work would be much appreciated.


(Jmiraglia) #4

Partial solution, you can still reference these repositories manually in the stackfile. It appears that autoredploy: true no longer works with 3rd party registry?