Docker Community Forums

Share and learn in the Docker community.

Problem with running bash script that in turn run a program with wine in docker a container

I have a bash script that sets up mounts to network locations and runs a docker container. One of the processes that is run through the docker container runs a windows application through wine. The issue I am having with this is that, the output does not get written to the mounted network drive if I run the application through the bash script. However, if I bypass the bash script and do “docker run” directly. Then inside the container I run the windows application with wine, I get the expected output written to the mounted network drive.

It seems that it is aproblem with the user when manually running things from inside the container contra user when running the container through the bash script. Or do I need to set some environmental variables?

Hi.

It’s hard for us to help diagnose/debug your problem without seeing details on the two different ways you are running your application.

1. Running your application from a bash script
2. Running your application from a "docker run" command

For me to help, I would need to see the contents of the bash script and the syntax of the docker run command you are running. And of course you can and should remove any sensitive information from either example if there is any.