Docker Community Forums

Share and learn in the Docker community.

Problem with static ip


I’m having a problem (that i didn’t have before formatting the computer yesterday and installing everything new) with assigning the static IP through the port with -p (Is important to have that one and not another one).


Error response from daemon: driver failed programming external connectivity on endpoint consulserver (d19f62859cd51191b54d9deb1073956f4c1ea0fa87117f717debbcb61d274073): Error starting userland proxy: listen udp bind: cannot assign requested address.

I have tried several things (first with docker-compose and after a few tries with docker directly and i haven’t been able to achieve that IP):
- I can make this work with a new network and a different IP.
- I cannot use that IP with docker-compose.
- I can use that IP if i create a network with “docker network” overriding the range from the bridge network, but then the bridge network is not usable until the computer is restarted.
- I have tried to uninstall the version of docker (to install a few older ones) with:
sudo apt-get purge -y docker-engine docker docker-ce
sudo apt-get autoremove -y --purge docker-engine docker docker-ce
- Maybe this is not the right way to delete it and i need to add more lines to do it?.

I’m using:
- Ubuntu - Version: 20.04
- Docker - Version: 19.03.12

Version where this worked two days ago (Not really sure):
- Ubuntu - Default version it came with the laptop, not really sure.
- Docker - Version: 19.03.11, also not really sure but seeing the dates of the release of the 19.03.12 i think this is the one i used.

Thanks : )