Problems starting DockerDesktop on working Chromeos/Crostini DockerEngine deployment

I am trying to configure DockerDesktop for Linux in a ChromeOS/Crostini deployment. After installation starting DockerDesktop the application forever reports the Engine is starting and the DockerCli fails when it tries to run hello-world

The initial starting point is a working Crostini deployment of DockerEngine and DockerCli following these instructions

  1. Install Docker Engine on Debian | Docker Documentation
  2. Docker Engine post-installation steps | Docker Documentation (group permission, systemctl, log rotation)

Next following the below instructions I tried to stall Docker Desktop for Linux.

  1. Install Gnome terminal
  2. Install from downloaded .deb file
  3. After installation starting the app prompts to setup credentials, which works fine

Result: DockerDesktop never comes online reporting the engine is starting. Also, the DockerCli no longer works when trying to run hello-world it tries to use $USER/.docker/desktop/docker.sock instead of /etc/run/docker.sock

Not sure what steps I should try next

The first socket path is fine. The other was I guess just incorrectly copied as it should be /var/run/docker.sock, but that is just a symbolic link to the first.

If it doesn’t work, it could be because Docker Desktop is not supported on ChromeOS

https://docs.docker.com/desktop/install/linux-install/#supported-platforms

If it can be run, I have no idea how. Maybe you could ask about it on a Chromeos forum. I don’t know if this is the right link: https://groups.google.com/a/chromium.org/g/chromium-os-discuss

Based on your links you tried a version built for debian. As far as I know it is not based on Debian and it is mainly for browsig the net, but I could find references to a feature that allows you to use apt as package manager. It is still not a Debian.