Docker Community Forums

Share and learn in the Docker community.

Proxy Issue Patch for DTR 1.1.0


(Andy Rothfusz) #1

Users who have configured DTR 1.1.0 to run behind a firewall may experience issues wherein proxy settings are not being respected by DTR containers. In addition, DTR 1.1 may not be able to reach the update servers from behind your firewall, so you won’t see when new versions are available. DTR 1.1 users are encouraged to update to DTR 1.2 manually (which will fix the proxy issues) and then use the update system in the web UI to do any future updates.

Execute this command to manually patch DTR 1.1.x to 1.2.0 and so remediate these issues.
Before you start, ensure that your Docker daemon is configured with correct proxy settings.

sudo bash -c "$(sudo docker run docker/trusted-registry upgrade 1.2.0)"

Note that you could also use this step to manually update DTR 1.1.1 to 1.2.0.


(Ebishop) #2

Thanks for the help!
However, the DTR Settings page doesn’t indicate the version, that I could
see. I ran: sudo bash -c “$(sudo
docker run docker/trusted-registry info)” | less, then looked for the
version.

Also, I was having
some docker group issues, so I still needed to use sudo for running docker
commands. So I needed anther sudo inside the parentheses:

sudo bash -c
"$(sudo docker run docker/trusted-registry stop)"

But the patch worked
nicely. Oh and the version IS on the
1.1.1 version of the setting page, but you know that. :slight_smile:

Thanks, again!