Docker Community Forums

Share and learn in the Docker community.

Pusing new images to DTR

docker

(Sjeeva) #1

Hello All,

I newly installed DTR (eval version) and tried to push a new image to the repository.

  1. Added my DTR as insure registry to the /etc/default/docker
  2. Logged into DTR as below
    $ docker login -u -p -e
  3. Pushed the image as shown below
    $ docker push //
    The push refers to a repository [//]
    e5d3e17598d4: Preparing
    5f70bf18a086: Preparing
    6f32b23ac95d: Preparing
    14d918629d81: Preparing
    fd0e26195ab2: Preparing
    unauthorized: authentication required
    The docker push failed with “unauthorized: authentication required” error message.
  4. I logged into DTR thru web, when to repository option and create a new manually and then the image push worked.

Is there away we can make the DTR to auto create the repository rather that doing thru the web interface?

Thanks,
Jeeva


(Jeff Anderson) #2

Auto create is not a current feature in DTR, although it is a commonly requested feature and is scoped for a future release.

Cheers!

/Jeff