Docker Community Forums

Share and learn in the Docker community.

Questions about the deploy-app Tutorial


(Vanderkerkoff) #1

Hello everyone

I’m following this tutorial, on a mac, using docker beta.

I’ve got my node sorted, and have done the tutorial prior to this one.

I’ve installed docker cli like so docker run dockercloud/cli -h

I’m having various issue with it, so probably best to start with the first one.

admins-MacBook-Air-3:default$ docker-cloud login

Please use “docker login” to log into Docker Cloud with you Docker ID"

Alternatively, you can set the following environment variables:

export DOCKERCLOUD_USER=<docker username>
export DOCKERCLOUD_PASS=<docker password>

I’ve set those variables in every place imaginable, and I can output them in the terminal

Any ideas why it’s forcing me to use docker login, which may be causing me issues further down the line?

Where am I supposed to set those variables in order to use docker-cloud login?

I can’t help feeling using docker for mac beta is messing with this process a bit.

Any tips or links I’d be extremely grateful.


(Vanderkerkoff) #2

I don’t think this bit works

Alternatively, you can set the following environment variables:

export DOCKERCLOUD_USER=
export DOCKERCLOUD_PASS=

Or if it does, I don’t know how you do it.

I’ve logged in with docker login for now, and worked something else out

This doesn’t work

trj260-mdmac:~$ docker-cloud repository ls
NAME IN_USE

This does

trj260-mdmac:~$ docker-cloud repository inspect VANDERKERKOFF/QUICKSTART-PYTHON
{
“name”: “vanderkerkoff/quickstart-python”,
“last_build_date”: null,
“public_url”: “https://registry-1.docker.io/_/vanderkerkoff/quickstart-python/”,
“in_use”: false,
“state”: “Empty”,
“registry”: “/api/repo/v1/vanderkerkoff/registry/registry-1.docker.io/”,
“build_source”: null,
“dockercloud_action_uri”: “”,
“tags”: [],
“resource_uri”: “/api/repo/v1/vanderkerkoff/repository/vanderkerkoff/quickstart-python/”
}

Think this may be a known bug

Moving on


(Joao Fernandes) #3

I also had the same problem myself. I was able to use something like this

docker run \
  -e DOCKERCLOUD_USER=<docker username> \
  -e DOCKERCLOUD_PASS=<docker password> \
  dockercloud/cli

You can find more information here


(Vanderkerkoff) #4

Hi Joao

I can’t get that to work either, not really sure what you are doing there to be honest, logging into docker-cloud or installing the cli?

I installed it ok, but can’t login with docker-cloud login


(Vanderkerkoff) #5

Ahh, sorry, I can see what your doing, you’re running it from the container.

I thought I’d try reading the docs(god forbid) here.

That approach isn’t working for me either, same error :frowning2:

The docker push is working though, I am communicating with my docker cloud after logging in with docker login, so I’m not really sure it’s worth continuing to try and work out what’s wrong. It’s obvioulsy something to do with my setup otherwise there’d be alot more people whinging.

I may try pip install out, then if that doesn’t work, move on.

Thanks for helping Joao


(Joao Fernandes) #6

Try running the dockercloud/cli image like this:

docker run -it \
  -e DOCKERCLOUD_USER=<your-user> \
  -e DOCKERCLOUD_PASS=<your-pass> \
  dockercloud/cli node ls

By running that command, I can successfully list the nodes in my cluster. Here are the public docs for the Docker cloud. You should be able to access those.


(Vanderkerkoff) #7

Hi Joao

Yep, that does work for me with nodes, but still doesn’t work with repository ls.

I’m moving on now, whilst it is a bit irritating, I can still access the data I need from the dockercloud UI.

Thanks for all your suggestions.

Matt