Docker Community Forums

Share and learn in the Docker community.

Reset Credentials missing

I’m using Docker for Windows (19.03.5) with Linux containers. I want to create a volume that is mapped to my windows file system. I have followed this link to create volumes and also tried creating using -v.

I have read the documentation here which states: “File sharing permissions are tied to the credentials you provide here. If you run docker commands under a different username than the one configured here, your containers cannot access the mounted volumes.”

The problem I have is that there are no options to reset credentials. I have seen screen shots that show a link at the bottom of the Resources/File Sharing page. Mine does not reflect this.

Does anyone else have this issue? Has anyone else successfully mounted a volume from the windows file system to a linux container?

Thanks for your help, I’m fairly new to docker!


Also having the same issue.

After update Docker Desktop to - i got the same problem. MySql DB in persistent storage volume was gone… Has anyone faced such a problem?
Update.I will explain.
When I trying to create container from image I match not empty windows foder with inner container folder:
-v //d/Data:/data
i do the same with mysql folder data:
-v //d/MySqlDockerData:/var/lib/mysql
Then I run the container’s bash and I see the folder /data is empty although it should not be such
I guess the reason - I need to reset credentials after update Docker Desktop. But such option is not available in version (at least I did not find it). I restarted docker several times, shared and unnshared folder (Settings/Resources/File Sharing) - I got the same result - the persistent folder is epmty…