Docker Community Forums

Share and learn in the Docker community.

[resolved] Image push from Docker Cloud highland builder to Docker Hub now fails with 'authentication required'


(Mark Henwood) #1

UPDATED 2: Resolved. Our billing had expired at Docker Hub and so we were unable to push to this private repo.

UPDATED I am receiving the same error when I try to push to the repo at Docker Hub from my local Mac. It therefore seems that I’m not allowed to push to this repo, which is owned by an Org of which I am an owner. Removing the ‘Docker Cloud’ tag**

We have a repository set up inside Docker Cloud which is located at Docker Hub. We’ve had this set up for months. Builds on our ‘master’ branch on this repo end with a push step to Docker Hub.

Since yesterday morning (21/11/2016) this push step has been failing consistently with the same error. It says:

Executing push hook...
running custom 'push' hook
on 'master' branch - pushing index.docker.io/org/foo-app:latest to repo
The push refers to a repository [docker.io/org/foo-app]
b0ff7d34a999: Preparing
0038570016c7: Preparing
[snip]
f934e33a54a6: Waiting
e7ebc6e16708: Waiting
5bc9fe967913: Waiting
unauthorized: authentication required

But there is no meaning to the idea of authenticating. It’s a builder (highland builder) doing a push under the authority of our organisation. This has always worked before.

Very stuck rn.