Docker Community Forums

Share and learn in the Docker community.

Security Scanning does not work?

dockersecurityscan

(Frank Felhoffer) #1

Hi,

I am trying to make the security scanning to work on my private repositories. I have tried to enable and disable the service, upload/delete containers, I even converter the user to an organization, but still nothing. I have followed the instructions here: https://docs.docker.com/docker-cloud/builds/image-scan/

Tried the hub and the cloud dashboards as well, but nothing indicates that the containers are scheduled for scanning at all.

Thanks,


(Pmerrison) #2

I have the same issue


(John Zaccone) #3

Same issue here as well


(John Zaccone) #4

Any updates on what might be going on with the security scanning service? Has it been discontinued?


(Vanderkerkoff) #5

Having the same issue here :frowning:


(Frank Felhoffer) #6

So I ended up testing the private registry to see how security scanning works there, but I run into some troubles and emailed to nautilus-feedback@docker.com for help. Someone replied me and also helped me to make the security scanning to work on my private repositories. When I enabled the scanning feature the back end did not pickup this event or something. It works since then.


(Claneax) #7

Same issue here. Enabled scanning, we’re on a paid plan, but nothing ever happens? Has anybody made any progress on this issue?


(Ryan Kennedy) #8

UPDATE: A fix has been deployed which addresses this issue. Any new tags pushed to a private repo with Docker Security Scanning enabled will trigger a corresponding scan. Also, for private repos that were impacted while this issue was occurring, the 3 latest tags (per repo) will also be scanned.

We apologize for the inconvenience and please let us know if you experience related issues in the future.


(Ryan Kennedy) #9