Docker Community Forums

Share and learn in the Docker community.

[SOLVED] Volumes Permissions erased by systemd-timesync

docker

#1

Hi,
I need your help with a recent issue with my volumes, especially with permissions.
Since a couple of day, permissions in /var/lib/docker/volumes are automatically reset at 775 by systemd-timesync user around every 10 seconds.

drwxrwxr-x 5 systemd-timesync users 4,0K nov. 28 09:19 gitlab_data
drwxrwxr-x 4 systemd-timesync users 4,0K janv. 6 16:20 gitlab_dataold
drwxrwxr-x 3 systemd-timesync users 4,0K sept. 1 22:59 logitechmediaserver_data
drwxrwxr-x 3 systemd-timesync users 4,0K mai 15 2018 madsonic_data

I have tried to force it to 777 and all is ok for 10 seconds and reseted just after.
I have read many things about it, like uid problems or systemd problems.

I have tried to use -u 1000:1000 in run ( + /etc/subuid …subgid), it not helps.
I have tried user remap too and it create more problems.

So I came here for the last chance !
It affect all my volumes.

I run docker 18.09.1 on ubuntu 18.04.1LTS

Please if someone can help me !!
Really thanks, and really sorry for this poor english :frowning:


#2

After many hours I solved my issue.
It was my samba container which shares /var/lib/docker/volumes who generates the problem.
I stopped It and all is OK now.

Thanks