Docker Community Forums

Share and learn in the Docker community.

Tag latest not found in repository


(Jakob Løkke Madsen) #1

I keep getting this error when I attempt to deploy:
ERROR: meteor-1: Tag latest not found in repository docker.io/jakobloekke/jks-candidate-presentations [28/6/2016 13.08.42]ERROR: Stack Redeploy action on 'jks-candidate-presentations' has failed

I’ve tried everything! Building locally and pushing. Building on DC infrastructure. Building with a different tag and trying to deploy that – that also fails.
I’ve tried building the image under a whole new name. No difference.

The image builds succesfully. The tags appear in the repository overview – both in the old and new UI.

It has worked for a long time, but the error seems to have started appearing during the weekend. So I have not been able to deploy for many days now.

I’ve opened a support ticket, but have not heard back yet.

Anyone else experiencing this?
I’m getting quite annoyed by this now, to be honest.


(Nlenaers) #2

Same here! I really can’t find a way to resolve this issue!


(Fernando Mayo) #3

Hello Jakob,

Can you SSH into the node and try to pull the image manually? I guess there’s some sort of data corruption on the engine database on that node, maybe caused by lack of space (we have seen this before). Does it happen to a one particular node?

Thanks,
Fernando.


(Pygmalios) #4

Hello there, I have a problem to redeploy docker services from public and private images at last last two days. I have also 31GB free space.

From service redeploy timeline:
ERROR: mongodb-1: Tag 3.2.9 not found in repository docker.io/library/mongo
ERROR: Service Redeploy action on ‘mongodb’ (using ‘mongo:3.2.9’) has failed

Or
ERROR: directory-1: Tag latest not found in repository docker.io/pygmalios/directory
ERROR: Service Redeploy action on ‘directory’ (using ‘pygmalios/directory:latest’) has failed

I am sure that tag exists in docker images. Private image has been built correctly.

Manual pull:

docker pull mongo:3.2.9

3.2.9: Pulling from library/mongo
30b7edbde36b: Extracting [==================================================>] 2.042 kB/2.042 kB
d2188e125b7a: Download complete
b9c34eda69e2: Pulling fs layer
deacd2a23457: Download complete
7c5e7bd4e5d8: Pulling fs layer
d56846085b77: Download complete
1c62897b541c: Download complete
febf8fd4ed07: Download complete
e010307a770b: Download complete
02cecb9fc024: Pulling fs layer
768210e169cf: Download complete
5dbb3ba7d850: Download complete
2cc62e3d6c57: Download complete
670b94f5cc20: Pulling fs layer
3e6417bb2100: Download complete
bbe0fbda725d: Download complete
Pulling repository docker.io/library/mongo
Tag 3.2.9 not found in repository docker.io/library/mongo