Docker Community Forums

Share and learn in the Docker community.

The running container failed after a few minutes [SOLVED]

Hi Docker experts,

I need help with the following issue.
If I run container then after a few minutes (ca. 10 minutes) “failes”. Here is the using docker command:

docker run -it --name 10.0.17763.1098 mcr.microsoft.com/windows/nanoserver:10.0.17763.1098

I am using the specific version of nanoserver because I wanted to exclude issue with incompatibility between host OS and container OS.

But the container is not actually failed because a state of the container is “Up” (as you can see below) and it looks like ready.

CONTAINER ID        IMAGE                                                  COMMAND                    CREATED             STATUS              PORTS               NAMES
421909cbbddf        mcr.microsoft.com/windows/nanoserver:10.0.17763.1098   "c:\\windows\\system32…"   6 hours ago         Up 6 hours                              10.0.17763.1098

But if I am trying to run for example following command:

docker exec 42 ipconfig

I get a following error:

container 421909cbbddfcdb5c6654229c6be343fb10b1c1f7ea51e517db9e169b5d80b46 encountered an error during CreateProcess: failure in a Windows system call: The remote procedure call failed and did not execute. (0x6bf) extra info: {"CommandLine":"ipconfig","User":"ContainerUser","WorkingDirectory":"/","CreateStdInPipe":true,"CreateStdOutPipe":true,"CreateStdErrPipe":true,"ConsoleSize":[0,0]}

So the container is in strange state and anyway it’s not possible to remove it. For removing is needed to restart docker engine.
I configured docker engine to debug mode for troubleshooting and I get a following error in system event viewer:

Faulting application name: vmcompute.exe, version: 10.0.17763.1075, time stamp: 0x2a322cae
Faulting module name: ntdll.dll, version: 10.0.17763.1098, time stamp: 0xfabbdc8a
Exception code: 0xc0000409
Fault offset: 0x00000000000a4730
Faulting process id: 0x1fe8
Faulting application start time: 0x01d602ae1fe1b02a
Faulting application path: C:\Windows\system32\vmcompute.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: adb8894d-51aa-4148-bb4f-02c3cc1c654f
Faulting package full name: 
Faulting package-relative application ID: 

It’s all what I found out. Could you help me please?

DOCKER VERSION

Client: Docker Engine - Enterprise
 Version:           19.03.5
 API version:       1.40
 Go version:        go1.12.12
 Git commit:        2ee0c57608
 Built:             11/13/2019 08:00:16
 OS/Arch:           windows/amd64
 Experimental:      false

Server: Docker Engine - Enterprise
 Engine:
  Version:          19.03.5
  API version:      1.40 (minimum version 1.24)
  Go version:       go1.12.12
  Git commit:       2ee0c57608
  Built:            11/13/2019 07:58:51
  OS/Arch:          windows/amd64
  Experimental:     false

HOST OS

Microsoft Windows Server 2019 Standard
Version 1809 (OS Build 10.0.17763.1098)

Maybe it’s good to mention that the Windows Server is virtualized on VMWare VM.

After downgrading the version of VMWare Tools to 10.3.10.12406962 it works. So the problem is solved.

Any thoughts as to why this was happening? Same thing is happening to me. using vm ware 11 with vsphere 6.7. Are you using iis in anyway with that nano server?

Was wondering if you found any more detail, also how did you get that system event error? I feel like docker system logging is lackluster.

VMware esxi?

I don’t know why this was happening. Obviously there is some incompatibility between VMWare version and Hyper-V but I didn’t find out more details.
I am not using iis in the nano server. It is clear image of nano server.
In the event log is more information if you run docker engine in debug mode but I agree that logging is lackluster. The mentioned error just was there. But the source of this error wasn’t docker but Application Error.

1 Like

I wanted to thank you for sharing this issue and the resolution. I was tearing my hair out trying to identify the problem, and the issue is very similar to the February 11, 2020 Windows update error. So I was chasing that red herring for days before I finally got the right search terms into the Google machine.

I experienced these exact symptoms under nearly identical circumstances - Windows Server 2019 LTSC build 1098, Docker for Windows 19.03.5, VMware ESX 6.7, VMware Tools greater than version 10.3.9. Rolling back to 10.3.2 solved the problem immediately.

I had a hunch it had something to do with nested virtualization, since Docker for Windows does seem to rely on the Hyper-V compute service even if one is not running in Hyper-V isolation mode. So thanks again for posting the fix.

1 Like