Docker Community Forums

Share and learn in the Docker community.

Trying to add sphinxsearch to my Container


(FLI) #1

Hello Docker-gurus!

I’m trying to get a newer version of Sphinx search to run in my Ubuntu 14.04 LTS Docker container. I’m running Docker on Windows 10.

If I just add RUN apt-get install sphinxsearch -y to my Dockerfile I get no errors, but the version installed is Sphinx 2.0.4-id64-release (r3135). I need to run 2.2.9 or newer.

So after much googling I have tried this:

RUN apt-get -y install software-properties-common RUN apt-get update RUN add-apt-repository -y ppa:builds/sphinxsearch-rel22 RUN apt-get update RUN apt-get -y install sphinxsearch

And I’ve tried this:

COPY /build-assets/sphinxsearch_2.2.10-release-0ubuntu12-trusty_amd64.deb /tmp/ RUN dpkg -i /tmp/sphinxsearch_2.2.10-release-0ubuntu12-trusty_amd64.deb

They both result in the same error:

Setting up sphinxsearch (2.2.10-release-0ubuntu12~trusty) ... invoke-rc.d: unknown initscript, /etc/init.d/sphinxsearch not found. invoke-rc.d: policy-rc.d denied execution of start.

Which later on makes my build fail for the following reason:

Step 14 : RUN service sphinxsearch restart ---> Running in 4fd77a4bdc3e sphinxsearch: unrecognized service ERROR: Service 'apachephpsphinx' failed to build: The command '/bin/sh -c service sphinxsearch restart' returned a non-zero code: 1

I’m out of ideas here, any help would be much appreciated!

Best Regards,
Fredrik


(FLI) #2

I solved this issue by upgrading from Trusty to Xenial.