Docker Community Forums

Share and learn in the Docker community.

UCP 1.0 Scaling not working as expected anymore


(Muellermich) #1

Today I upgraded my test installation from 0.9 to 1.0. A started a complete new installation.

When I create a container and want to automatically expose all ports (-P) and want to scale this container later. The new containers don’t expose the port anymore. It doesn’t matter if this is done via GUI or CLI.
This was working in version 0.9. Has here been any change or how can I get around that?

Cheers


(Alm. Brand Docker admins) #2

I was able to reproduce this - not very practical if those scaled-up containers are supposed to serve any traffic…


(Muellermich) #3

Not realy!
As a workaround you could easily do n=0; while (( n++ < 10 )); do docker run -d -P containername; done, but it would be good to have this feature back.


(Alm. Brand Docker admins) #4

That would only work for containers that don’t require complex arguments to the docker run command, e.g. setting extra --env or --label options.

Have you tried using the scale command from docker-compose?


(Muellermich) #5

If they use the same --env or --label it will work. But for sure for complex stuff, it will not work out. I’ll test to scale with compose maybe later when I find the time.


(Vivek Saraswat) #6

Thanks for the feedback, can confirm this is happening. I will flag it for the dev team.

Let me know if you see any other similar issues!