Docker Community Forums

Share and learn in the Docker community.

UCP 3.0.8 Upgrade to UCP 3.1.3 on CentOS 7 with Docker EE 18.9.0.1 Issues


(Chris Fortner) #1

Performed a UCP upgrade from 3.0.8 to 3.1.3 and the upgrade completed. After the upgrade I logged back into the dashboard and the graphs were not showing. The page would show a spinning circle and then eventually an error saying “load failed” would appear where graphs would normally be shown.

I left the cluster in this state and was going to open a ticket the next morning to resolve the graph issues but during the night all my manager nodes spiked the CPU to 100% and my cluster crashed. All my containers in my swarm stopped.

I ended up having to downgrade my UCP back to UCP 3.0.8 as even after reboots of all nodes with UCP 3.1.3 did not restore the cluster to a healthy state.

After the downgrade back to UCP 3.0.8 all services are now working properly again.

Anyone else running into issues with UCP 3.1.3 on CentOS 7?


(Medavie) #2

Have you tried connecting with Docker Support?

I’m planning on moving my clusters from 17.06 / UCP 2.2.12 to 18.09 3.0.8 Then 3.1.3…

I tried it in a lab and had to restart the actual VM’s in my UCP Randomly to get them to all show healthy…
With that… I did notice my lab worker node went into a bad state during a period of me not watching it.


(Chris Fortner) #3

I did open a ticket with support but I basically got back an answer of we can’t help unless you recreate the issue and then contact us. So I am waiting for another change window in which to try it again and then engage support.