Docker Community Forums

Share and learn in the Docker community.

UCP and overlay networks (Internal Server Error)

(Mreferre) #1

I am trying to create an overlay network on a newly created UCP 1.1.0 cluster and I am getting an Internal Server error.

A quick google search brought this up: Fail to create network - failed to parse pool request

That’s exactly the same problem I have (apparently).

I was expecting UCP to configure engine / swarm properly to have the overlay network to work out of the box. Also because I went through the UCP installation document (for production) and there is no mention of these tweaks that are being suggested in the thread above.

Before I boil the ocean and dive into all of those tweaks, is this still the case? I find it odd that UCP doesn’t configure stuff properly but I find it even odder that the documentation makes no mention of it.

Or am I missing something (as usual)?


/cc @anoop

(Vivek Saraswat) #2

As mentioned in the production install docs, multi-host-networking should be automatically configured in UCP 1.1.0, particularly if you are running Engine 1.11. If you are having issues, take a look at the section We are updating that doc with the fact that we now automatically run engine-discovery during node join, but the process should be the same. If that doesn’t seem to work I can try to help walk through the issue.

(Mreferre) #3

Oh I didn’t see that part. I thought this should have been included in the installation rather than in the configuration. Especially since you give such a black eye when someone (at the end of the setup tries to create an overlay). An Internal Error 500 is quite a big deal :slight_smile:

If you intend to keep that part in the configuration I suggest you spit a less dramatic message (e.g. “distributed networking hasn’t been configured yet”).

I’ll go through that. Thanks.

(Mreferre) #4

@vsaraswat following the steps in the link you provided made the trick. I am now able to create overlay networks. Note my setup was 1.0.4 (IIRC) which has then been upgraded to 1.1.0 when you made it available. Not sure if a straight setup of 1.1.0 will configure the plumbing without going through this manual process (haven’t tried it).

BTW note that the command as described in your link resulted in a:

   INFO[0000] Configuration was not updated. Provide the '--update' option to apply changes, or re-run in debug mode to see changes. 

I had to add a “–update” to the syntax to actually make it work.


(Vivek Saraswat) #5

@mreferre thanks for the feedback, I’ll make sure that --update gets added into the docs. Straight 1.1.0 running on Engine 1.11 would auto-configure most of the plumbing for you, but when upgrading some of it is manual with the engine-discovery tool.