Docker Community Forums

Share and learn in the Docker community.

UCP Beta install fails - engine is too old


(Qurujames) #1

Hi all,

I’m working through the instructions for the 30 day trial of Docker Datacenter. However I’ve hit and issue with the UCP beta install.

Following the Docker CS engine setup instructions, I added the Docker 1.9 package source for Ubuntu:

echo “deb https://packages.docker.com/1.9/apt/repo ubuntu-trusty main” | sudo tee /etc/apt/sources.list.d/docker.list

Then proceed to install Docker - resulting in engine version 1.9.1.

I then run “docker run --rm -it docker/ucp install --help” as per the installation instructions for UCP which pulls down the container just fine - however when I run:

docker run --rm -it -v /var/run/docker.sock:/var/run/docker.sock --name ucp docker/ucp install -i

I see:

INFO[0000] Verifying your system is compatible with UCP
FATA[0000] Your engine version 1.9.1 is too old. UCP requires at least version 1.10.0.

Are Docker CS 1.10.0 packages available yet, and if so can someone guide me on how to install them? Alternatively is there a version of UCP beta that doesn’t require the 1.10 engine I can install?

Kind regards,

James


(Sebastiaan van Steenis) #2

Check out this post for requirements, it does indeed require 1.10 and you can use the open-source engine for now:


(Vivek Saraswat) #3

That’s correct. As an update, the CS Engine 1.10 Release Candidate is now available:

https://packages.docker.com/dtr/1.4/dtr-1.4.3-rc2.tar

While this is not a supported version, it can be used for testing purposes with the UCP Beta until the GA release of CS Engine 1.10 is available.


(Daniel) #4

Hi qurujames

You can reference

or

curl -fsSL https://get.docker.com/ | sh

this can solve my problem

:slightly_smiling: