Docker Community Forums

Share and learn in the Docker community.

Ucp fail to deploy due to blocked ports

(Jacob Roy) #1

Hi , I am getting the following error while trying to deploy ucp. I have opened up ports as well as tried on different ports with the swarm-port argument, but still getting the same error.
Also I have disabled the firewalld as well.
Any solution for this. ?

You may enter additional aliases (SANs) now or press enter to proceed with the above list.
Additional aliases:
FATA[0013] The following required ports are already in use on your host - 12386, 12379, 12382, 12380, 3376, 4789, 443, 12376, 12381, 12383, 12384, 12385, 12387. You may specify an alternative port number to 3376 with the --swarm-port argument.

(Joao Fernandes) #2

I’ve seen a similar error in the past when I was using the wrong IP address with the --host-address flag. So make sure you’re using the right IP address.

It needs to be an IP address that other nodes can reach, but the node itself must be able to reach it.

(Jacob Roy) #3

Hi, Joe
Thanks for your response. Actually I did made sure that I was putting the correct --host-address flag.
When I did the following steps, I was able to deploy UCP successfully on the preferred node.

  1. I edited /etc/hosts file, added the host entry in the hosts file which I haven’t done for the previous installation.
  2. I disabled and stopped “”“firewalld”" service.
  3. Reboot the system.
  4. Once rebooted, I re-ran docker deploy command and installation was successfull.

(Joao Fernandes) #4

From what you’re describing, it seems that it might be a firewall issue.
I’m sure you’ll want to re-enable your firewall. When you do that, make sure you have these ports open.

(Jacob Roy) #5

Yes its due to the Firewall, this is happening and was having same issue while adding the nodes to the swarm.
I had to do the same steps mentioned above for joining the nodes to the swarm successfully.

Thanks for your help!!!:slightly_smiling_face: