Docker Community Forums

Share and learn in the Docker community.

UCP installation issue - Host not starting ... no error!


(Pycloux) #1

Hi
I am installing UCP (current version) on a Centos 7.1 with DockerEngine 1.10 box (a physical one) with a public address and a host name.
Running the install seems to work (hostname detected as well as public IP) but the installation fails at the very end.

See the end of the installation logs below (I replaced my real IP with <>):

INFO[0065] Deploying UCP Containers
DEBU[0065] Starting KV container
DEBU[0067] Internal KV started at etcd://<>:12379
DEBU[0067] Starting docker proxy
DEBU[0068] Proxy started on <>:12376
DEBU[0068] Checking for liveness of https://<>:12376
ERRO[0128] We were unable to communicate with proxy we just started at address <>. Did you forget to specify an alternate DNS server with the ‘–dns’ flag? If this address is incorrect, re-run the install using the ‘–host-address’ option. Run “docker logs ucp-proxy” for more details from the proxy

The ucp-proxy is indeed listening on 12376.

If I check with wget:
wget --no-check-certificate https://<>:12376
–2016-02-06 19:06:30-- https://<>:12376/
Connecting to <>:12376… connected.
WARNING: cannot verify <>'s certificate, issued by ‘/CN=Swarm Root CA’:
Unable to locally verify the issuer’s authority.
HTTP request sent, awaiting response… 404 Not Found
2016-02-06 19:06:30 ERROR 404: Not Found.

When I get the logs of the ucp-proxy container I get:
time=“2016-02-06T17:40:48Z” level=info msg="docker proxy"
time=“2016-02-06T17:40:48Z” level=info msg="Configuring TLS: cert=/etc/docker/ssl/cert.pem key=/etc/docker/ssl/key.pem"
Using TLS
Listening on 2376

Any clue ?


Can't spawn ucp (0.7.1, 0.8.0, 1.0.0, 1.0.1) on CentOS 7.2 - unable to communicate with proyx at https://host:12376
(Sune Keller) #2

firewalld? UCP Beta v0.8 now available!


(Pycloux) #3

Hi Sune,

Actually, firewalld is de-activated on my CentOS.
I have only iptables and the install process of UCP seems to open correctly the ports.
Besides, I can access the proxy port from the internet, so I guess that everything is opened correctly.

Best regards,

PYC