Docker Community Forums

Share and learn in the Docker community.

Unable to browse demo containers

dockercloud

(Toby Griffiths) #1

I’m new to Docker Cloud. I’ve been following the tutorial here…

… but having connected to my digital ocean account & provisioned my node cluster, when I build, push & run either the quickstart-python or the quickstart-go apps, I can’t connect to either of the in the browser. I get a connection refused.

The Hello World example worked fine.

Any ideas on how I diagnose why I can’t connect?


(Toby Griffiths) #2

OK. I’ve done a little more digging, & if I run…

$ curl http://localhost

… I get…

<h1>hello, world</h1>                                                                                                                          
<b>Hostname: </b>web-go-1<br><b>MongoDB Status: </b>Not available

But in my own browser I get the message…

web-go-1.7d239e7c.cont.dockerapp.io refused to connect.

Any idea why my local machine won’t connect?


(Toby Griffiths) #3

Hmmm… and now more info…

I’ve redeployed both the python & go app containers. The python app then started working, but the go one didn’t, so re-deployed it again & now it’s working.

Is it just me, or does this feel like it’s not stable enough yet?


(Lee Hull) #4

A few things to keep in mind…

  • Make sure you are exposing the public port
  • Make sure your node (cloud provider) does not have the port blocked in its firewall

It is pretty stable but takes a little getting use