Docker Community Forums

Share and learn in the Docker community.

Unable to convert user account to organization: "Please enter a valid Docker ID"

I’ve really been struggling managing docker hub for the past 2 weeks. I’m trying to create an organization called ‘seeloz’. But I ended up creating a user called ‘seeloz’. I upgraded my plan and added some repos to it. Then I realized that I have to convert it into an organization. But try as I may I keep getting an error saying “Please enter a valid Docker ID” no matter what docker user id I give (trying to add, ‘salqadri’, to it). I even tried creating brand new docker ids with nothing in them at all, and even then I would get the same error. I read all existing documentation about this issue to no avail. I even tried removing all the repos from the ‘seeloz’ account, and still it didn’t work. I even tried downgrading back to a free account.

Also btw during all this I also had tried to create another organization called ‘seelozinc’ from within my ‘salqadri’ user account, which I discovered I would need to pay again, so I deleted that organization. But it seems it wasn’t completely deleted as whenever I try creating it again, it complains that it already exists.

I tried submitting help requests a couple of times through the form at https://success.docker.com/support but never get any response.