Docker Community Forums

Share and learn in the Docker community.

Uninstalling DTR doesn't update UCP UI


(John Harris) #1

As title :slight_smile: I had a single replica DTR installed. Uninstalled it (following the instructions), but it still shows up in UCP > Admin > DTR. Anyway to remove it?


(Patrick Devine) #2

Hey John,

Did you use the docker run -it --rm docker/dtr remove --ucp-insecure-tls command to uninstall? Also, can you look on the node w/ docker ps -a to make certain the containers are gone?


(John Harris) #3

Actually I used destroy I believe. Containers are gone (only ucp-agent and ucp-proxy remain). That DTR is gone from my application list, but remains in Admin > DTR.


(Joao Fernandes) #4

I was able to reproduce this, and filed an issue internally so that we can fix it.
Thanks for reporting!


(John Harris) #5

Thanks Joao!

(extra character blah blah forums)


(Cheryl) #6

Hi John,

Not sure if you managed to resolve the issue but I found this KB article that would probably solve it:
https://success.docker.com/KBase/Multiple_DTRs_shown_when_only_one_exists


(Manglu) #7

Hi Joao,

Is this problem fixed? I encountered this same problem yesterday (in the latest versions of UCP and DTR)

Appreciate any help!


#8

Using latest Docker 2.1, and I can’t remove DTR entries following article:

I’m also trying directly by editing and uploading toml files, but still no removal.

curl --cacert ca.pem --cert cert.pem --key key.pem https://ucp1:5443/api/ucp/config-toml > ucp-config.toml
curl --cacert ca.pem --cert cert.pem --key key.pem --upload-file ucp-config.toml https://ucp1:5443/api/ucp/config-toml


(Fsejoseph) #9

Things have changed this works now

https://success.docker.com/article/extra-dtr-listed-in-ucp-31x-requiring-removal