Docker Community Forums

Share and learn in the Docker community.

Unusable on OSX/virtualbox due to performance issue


(Pnwtrifork) #1

I’ve been using docker-machine with virtualbox for about 2 months. Until about a week or two ago, everything worked great.

However, something has happened and now many docker cli command takes minutes to complete. For example, if I do a pull on a container, it takes approx 20 minutes to acquire a small image. If I pull an image that already exists, it takes about 5 minutes. More recently, everything takes so long to complete, I haven’t bothered to time. I provide the pull example, but I also have the same issue exec’ing, running, etc.

I have upgraded the client to 1.7.1, reinstalled the recommended virtualbox version .28, restarted, attempted to delete all old folders (e.g. .docker .virtualbox, etc). Reinstalled docker-machine. And still the same issues.

I’ve tried to add -loglevel=debug but it doesn’t give any more information. Please note that this has worked perfectly in the past, so it’s not an installation issue. I suspect there is a temp folder or cache or something that has caused the problem.

Could anyone provide me with instructions to help me debug this?

– Update: I’ve just tried it with a VMWare Fusion demo, and that works fine. So it appears it’s something to do with virtualbox.

Thanks,
Phil