Docker Community Forums

Share and learn in the Docker community.

Updating Perl inside docker contaienr

Hey

I’m very new to docker and linux for that matter.
i’ve been running Logitech Media Server but every build only has audio::scan 0.95
I need it to be 1.0.2 to support opus file formats
If i read correctly i need to update perl for this to version 5.24 or 5.26

How would I go about this?

Same problem, you can download perl in the official website, it worked for me

i’m not sure how i go about installing it though, lost several hours googling this issue
Or maybe you would be so kind to share your docker image?

There are official Perl images, but I think you confound two things. The version of Audio::Scan is not related to the Perl version. The most recent version is 1.01, not 1.02 (see here) and you can install it with

cpanm Audio::Scan

in your Dockerfile. Just tried it, it installs even on Perl 5.16.

wow ok, that’s great new, i’ll try this. thanks a lot!

edit. I’m getting the same error in different containers. No idea what it means

Running make for B/BI/BIGJ/Test-Warn-0.36.tar.gz
Warning: Prerequisite ‘Sub::Uplevel => 0.12’ for ‘BIGJ/Test-Warn-0.36.tar.gz’ failed when processing ‘DAGOLDEN/Sub-Uplevel-0.2800.tar.gz’ with ‘make => NO’. Continuing, but chances to succeed are limited.
BIGJ/Test-Warn-0.36.tar.gz
make – NOT OK
AGRUNDMA/Audio-Scan-1.01.tar.gz
Has already been unwrapped into directory /root/.cpan/build/Audio-Scan-1.01-OQEJP3
AGRUNDMA/Audio-Scan-1.01.tar.gz
Has already been prepared
Running make for A/AG/AGRUNDMA/Audio-Scan-1.01.tar.gz
Warning: Prerequisite ‘Test::Warn => 0’ for ‘AGRUNDMA/Audio-Scan-1.01.tar.gz’ failed when processing ‘BIGJ/Test-Warn-0.36.tar.gz’ with ‘make => NO’. Continuing, but chances to succeed are limited.
AGRUNDMA/Audio-Scan-1.01.tar.gz
make – NOT OK

This means the installation of module Test::Warn fails. Difficult to tell the reason when I don’t know how you build your image.
You could try cpanm --notest Audio::Scan, but as the options says this will install it untested.