Docker Community Forums

Share and learn in the Docker community.

Upgrade swarm to 1.1.0 instead of 1.1.0-rc2?


(Sune Keller) #1

I don’t see any flags which would let me do that, but I suspect the -rc2 version to be the cause of some unexpected behavior. Specifically I get this error when using the --filter option to docker ps:

json: cannot unmarshal object into Go value of type []string

This is by the way only when pointing my Docker CLI towards UCP. If I point it at the swarm manager’s port instead, I don’t get the error.


(Vivek Saraswat) #2

Hi Sune,

Yup, looks like a potential Swarm error. While UCP 0.8 beta does use Swarm 1.1.0-rc2. In general we don’t allow UCP to independently upgrade Swarm in order to ensure full stack testing and compatibility for our features. However, UCP 1.0 GA will use Swarm 1.1.0.


(Alm. Brand Docker admins) #3

Just writing here to confirm this can be reproduced with UCP 0.9.0 (Swarm image: docker/ucp-swarm:0.9.0, UCP image: docker/ucp:0.9.0). The error message is the same.
– Sune @ Alm. Brand


`docker ps --filter` does not work against UCP endpoint