Docker Community Forums

Share and learn in the Docker community.

Validation error with no reason when updating stack

teamsorganizations

(Arnaud de Mouhy) #1

Hello there,

I get a strange error when creating/updating a stack in organization mode. Found in javascript console: “401 (UNAUTHORIZED)”, and message in timeline : “ERROR: Validation Error: {“error”: “”}”

I am trying to create a service with a public image, and it’s a copy/paste of a stack already working on my “personal” team.

The strange thing is that it fails for some services (I try a add services in the stack one by one to check validity), but it worked for some others. My private image services do not work, and some public images fail.

For bug search & destroy, the stack id : c4ec6cc8-b062-4fef-b796-358d7576f4e2


'volumes_from' not working on organization accounts?
(Arnaud de Mouhy) #2

I found that it is a volume matter.

I have a service “service-data”, busybox based, “tail -f” command to stay up, writable volume /data. It start with no problem.
I have a service “service”, public image, no volumes_from. No problem starting.
I edit this service, add a volumes_from the “service-data”, try to save and boum, error. :frowning:


(Andrewalexmac) #3

Also experiencing the same issue, but it seems that volumes_from that were created before converting my cloud from a user to org keep working somewhat. Didn’t notice problems until I rebooted my node and tried editing stackfiles to diagnose the issues. I stupidly terminated the service before checking the forums and now I can’t recreate it…


(Pablo Chico de Guzman Huerta) #4

The fix is now live in production.