Docker Community Forums

Share and learn in the Docker community.

Waiting for docker server to be up


(Abibao) #1

Hi,

I’m a user of the service since the very begining of ex-tutum, so I know how all works.
6 month later, on my own node, I use vagrant to create two VMs.
Each VMs was perfectly and quickly ready for dockerclound, I made a lot of stuff with them and never have a problem.

Today, this thime, I tried to bring the server himself has a node, because I don’t want to have VMs anymore. So I do as usual with the script and then… BAM! PLAF! OUCH! nothing works.

In logs I have this :16/10/29 13:30:57 Updating configuration file…
2016/10/29 13:30:58 New TLS certificates generated
2016/10/29 13:30:58 Registering in Docker Cloud via PATCH: https://cloud.docker.com/api/agent/v1/node/8736b15e-c84c-4e6b-962d-daee45366ca8
2016/10/29 13:30:58 Found docker: version 1.11.2-cs5
2016/10/29 13:30:58 Initializing docker daemon
2016/10/29 13:30:58 Loading NAT tunnel module
2016/10/29 13:30:58 Verifying the registration with Docker Cloud
2016/10/29 13:30:58 Docker server started. Entering maintenance loop
2016/10/29 13:30:58 Waiting for docker unix socket to be ready
2016/10/29 13:30:58 Starting docker daemon: [/usr/bin/docker daemon -H unix:///var/run/docker.sock -H tcp://0.0.0.0:2375 --userland-proxy=false --tlscert /etc/dockercloud/agent/cert.pem --tlskey /etc/dockercloud/agent/key.pem --tlscacert /etc/dockercloud/agent/ca.pem --tlsverify]
2016/10/29 13:30:58 Docker daemon (PID:23457) has been started
2016/10/29 13:31:00 Docker unix socket opened
2016/10/29 13:31:00 Node 8736b15e-c84c-4e6b-962d-daee45366ca8.node.dockerapp.io is publicly reachable

And then in the dockerckoud i have this :
Waiting for docker server to be up…
Waiting for docker server to be up…
Waiting for docker server to be up…
Waiting for docker server to be up…
Instance has been removed from Docker Cloud
PLEASE NOTE: we have not shut down the underlying host as it was not created by Docker Cloud
ERROR: Unable to connect to the Docker daemon in 8736b15e-c84c-4e6b-962d-daee45366ca8.node.dockerapp.io. Please try to restart the Docker Cloud agent and contact support if the problem persists.
Reallocating containers in other nodes…
Reallocation done!

I tried to remove and reinstall, problem not solved.

When I do : docker images, I don’t have any weaves, etc…

Helps will be a good thing please :slight_smile: