Docker Community Forums

Share and learn in the Docker community.

What is meant my "available container slots" in an error?


(Ralph Kincade) #1

FATA[0001] Problem running container ‘dtr-phase2’ from image ‘docker/dtr:2.0.2’: Couldn’t create container ‘dtr-phase2’ from image ‘docker/dtr:2.0.2’: Error response from daemon: Unable to find a node that satisfies the following conditions
_

[available container slots]

thanks !!!
_


(Nickdoikov) #2

check ports availability.
In most cases this errors mean resources absence or port allocation by other app.

check this issue - it is seems like closest to yours:


(Ralph Kincade) #3

Nick , i have been trying for hours and hours to get this to work to no avail , I have attempted use port 81 and 444 and still get the same error , but it just references the 444 and 81 port . I am trying a different solution , i am attempting to get a brand new node set up and use a different ports other than the default to attach to the existing UCP cluster .

then I will attempt to re-run the DTR with default command line install so that IT gets the 443 and 80

I am thinking this is a bug and will need to be fixed

thanks


(Nickdoikov) #4

I do not think that it is a bug in image , if you think so - you can install earliest versions e.g. 2.0.0 or 2.0.1