Docker Community Forums

Share and learn in the Docker community.

What is the command (if any) to see what registry you are connected to? to


(Ralph Kincade) #1

I know /home/user/.dockercfg has this value and I can cat it

is there a single command to do this ???

thanks


(Andy Rothfusz) #2

There is no active connection between the client, the daemon and a registry. The connection gets made when you docker run, push, pull etc, when you specify the repository you want to work with.

So, at any time, if your repository specification does not include a full path, docker will assume you mean index.docker.io as the registry. It doesn’t matter what is in /.dockercfg because you can always pull public images from index.docker.io, even if you’re not logged-in.

A full path looks like

docker pull my.registry.machine:port/username/reponame:tagname

When you don’t specify my.registry.machine:port then docker assumes index.docker.io:80.


(Ralph Kincade) #3

thanks for all the help on this but I am still having issues with syntax

I am using “docker push docker-cs0.int.bork .com:80/admin/mybusybo”

and I get
FATA[0000] Error response from daemon: v1 ping attempt failed with error: Get https://docker-cs0.int.vizuri.com:80/v1/_ping: tls: oversized record received with length 20527. If this private registry supports only HTTP or HTTPS with an unknown CA certificate, please add --insecure-registry docker-cs0.int.bork.com:80 to the daemon’s arguments. In the case of HTTPS, if you have access to the registry’s CA certificate, no need for the flag; simply place the CA certificate at /etc/docker/certs.d/docker-cs0.int.bork.com:80/ca.crt
user@docker-cs1:~$

I am not seeing in the DTR repository where to create a repo so I am not sure what to put in the place of “reponame” in you full path example

I know I am messed up with the syntax here somehow

thanks