Docker Community Forums

Share and learn in the Docker community.

WordPress example doesn't start the web container


(Steve Freeman) #1

Expected behavior

The web container would start up and service requests.

Actual behavior

E:\Docker\WordPress>docker-compose up
Starting wordpress_db_1
Recreating wordpress_web_1
Attaching to wordpress_db_1, wordpress_web_1
db_1 | 160415 15:45:58 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 15:45:59 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
web_1 | Directory /code/wordpress/ does not exist.
db_1 | 160415 15:45:59 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 15:45:59 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 15:45:59 [Note] Plugin ‘FEDERATED’ is disabled.
db_1 | 160415 15:45:59 InnoDB: The InnoDB memory heap is disabled
db_1 | 160415 15:45:59 InnoDB: Mutexes and rw_locks use GCC atomic builtins
db_1 | 160415 15:45:59 InnoDB: Compressed tables use zlib 1.2.3.4
db_1 | 160415 15:45:59 InnoDB: Initializing buffer pool, size = 128.0M
db_1 | 160415 15:45:59 InnoDB: Completed initialization of buffer pool
db_1 | 160415 15:45:59 InnoDB: highest supported file format is Barracuda.
db_1 | 160415 15:45:59 InnoDB: Waiting for the background threads to start
wordpress_web_1 exited with code 1

Information

Windows beta.

When I replace the command with “ls -l /” I can see the /code path, but “ls -l /code” returns nothing. There should at least be a few files in that directory as well as the wordpress subdirectory.

Steps to reproduce the behavior

Follow the example.


(Tonći Vatavuk) #2

Had the same problem.

Than moved folder my-wordpress with example from some location on drive D: to C:\Docker
After executing docker-compose up command in new location C:\Docker\my-wordpress\ example with wordpress is working ok.

Currently playing with with older D4W Beta6 version on current Windows 10 Insider Preview…

[21:57:01.635][Program ][Info ] Version: 1.10.6.958
[21:57:01.637][Program ][Info ] Starting on: 4/15/2016 9:57:01 PM
[21:57:01.639][Program ][Info ] Resources: C:\Program Files (x86)\Docker\Docker\Resources
[21:57:01.641][Program ][Info ] OS: Windows 10 Pro Insider Preview
[21:57:01.642][Program ][Info ] Edition: Professional
[21:57:01.644][Program ][Info ] Id: 1511
[21:57:01.646][Program ][Info ] Build: 14316
[21:57:01.648][Program ][Info ] BuildLabName: 14316.1000.amd64fre.rs1_release.160402-2217

c:\Docker\my-wordpress>docker-compose up
Starting mywordpress_db_1
Recreating mywordpress_web_1
Attaching to mywordpress_db_1, mywordpress_web_1
db_1 | 160415 20:16:38 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 20:16:42 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 20:16:42 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 20:16:42 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 20:16:42 [Note] Plugin ‘FEDERATED’ is disabled.
db_1 | 160415 20:16:42 InnoDB: The InnoDB memory heap is disabled
db_1 | 160415 20:16:42 InnoDB: Mutexes and rw_locks use GCC atomic builtins
db_1 | 160415 20:16:42 InnoDB: Compressed tables use zlib 1.2.3.4
db_1 | 160415 20:16:42 InnoDB: Initializing buffer pool, size = 128.0M
db_1 | 160415 20:16:42 InnoDB: Completed initialization of buffer pool
db_1 | 160415 20:16:42 InnoDB: highest supported file format is Barracuda.
db_1 | 160415 20:16:43 InnoDB: Waiting for the background threads to start
db_1 | 160415 20:16:44 InnoDB: 5.5.38 started; log sequence number 1595675
db_1 | 160415 20:16:44 InnoDB: Starting shutdown…
db_1 | 160415 20:16:44 InnoDB: Shutdown completed; log sequence number 1595675
db_1 | 160415 20:16:44 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 20:16:44 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
db_1 | 160415 20:16:44 [Note] Plugin ‘FEDERATED’ is disabled.
db_1 | 160415 20:16:44 InnoDB: The InnoDB memory heap is disabled
db_1 | 160415 20:16:44 InnoDB: Mutexes and rw_locks use GCC atomic builtins
db_1 | 160415 20:16:44 InnoDB: Compressed tables use zlib 1.2.3.4
db_1 | 160415 20:16:44 InnoDB: Initializing buffer pool, size = 128.0M
db_1 | 160415 20:16:44 InnoDB: Completed initialization of buffer pool
db_1 | 160415 20:16:44 InnoDB: highest supported file format is Barracuda.
db_1 | 160415 20:16:45 InnoDB: Waiting for the background threads to start
db_1 | 160415 20:16:46 InnoDB: 5.5.38 started; log sequence number 1595675
db_1 | 160415 20:16:46 [Note] Server hostname (bind-address): ‘0.0.0.0’; port: 3306
db_1 | 160415 20:16:46 [Note] - ‘0.0.0.0’ resolves to ‘0.0.0.0’;
db_1 | 160415 20:16:46 [Note] Server socket created on IP: ‘0.0.0.0’.
db_1 | 160415 20:16:46 [Note] Event Scheduler: Loaded 0 events
db_1 | 160415 20:16:46 [Note] /usr/sbin/mysqld: ready for connections.
db_1 | Version: ‘5.5.38-0ubuntu0.12.04.1-log’ socket: ‘/var/run/mysqld/mysqld.sock’ port: 3306 (Ubuntu)
web_1 | [Fri Apr 15 20:17:59 2016] 10.0.75.1:51112 [302]: /
web_1 | [Fri Apr 15 20:18:02 2016] 10.0.75.1:51113 [200]: /wp-admin/install.php
web_1 | [Fri Apr 15 20:18:02 2016] 10.0.75.1:51115 [200]: /wp-includes/css/buttons.min.css?ver=4.5
web_1 | [Fri Apr 15 20:18:02 2016] 10.0.75.1:51116 [200]: /wp-admin/css/install.min.css?ver=4.5
web_1 | [Fri Apr 15 20:18:02 2016] 10.0.75.1:51117 [200]: /wp-includes/css/dashicons.min.css?ver=4.5
web_1 | [Fri Apr 15 20:18:03 2016] 10.0.75.1:51119 [200]: /wp-includes/js/jquery/jquery.js?ver=1.12.3
web_1 | [Fri Apr 15 20:18:03 2016] 10.0.75.1:51120 [200]: /wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.0
web_1 | [Fri Apr 15 20:18:03 2016] 10.0.75.1:51118 [200]: /wp-admin/js/language-chooser.min.js?ver=4.5
web_1 | [Fri Apr 15 20:18:03 2016] 10.0.75.1:51121 [200]: /wp-admin/images/spinner.gif
web_1 | [Fri Apr 15 20:18:03 2016] 10.0.75.1:51122 [200]: /wp-admin/images/wordpress-logo.svg?ver=20131107
web_1 | [Fri Apr 15 20:18:03 2016] 10.0.75.1:51123 [404]: /favicon.ico - No such file or directory
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51125 [200]: /wp-admin/install.php?step=1
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51126 [200]: /wp-includes/css/buttons.min.css?ver=4.5
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51128 [200]: /wp-includes/css/dashicons.min.css?ver=4.5
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51127 [200]: /wp-admin/css/install.min.css?ver=4.5
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51130 [200]: /wp-includes/js/jquery/jquery.js?ver=1.12.3
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51129 [200]: /wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.0
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51131 [200]: /wp-includes/js/zxcvbn-async.min.js?ver=1.0
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51132 [200]: /wp-admin/js/password-strength-meter.min.js?ver=4.5
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51133 [200]: /wp-includes/js/underscore.min.js?ver=1.8.3
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51134 [200]: /wp-includes/js/wp-util.min.js?ver=4.5
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51135 [200]: /wp-admin/js/user-profile.min.js?ver=4.5
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51136 [200]: /wp-admin/images/wordpress-logo.svg?ver=20131107
web_1 | [Fri Apr 15 20:18:23 2016] 10.0.75.1:51137 [200]: /wp-includes/js/zxcvbn.min.js


(Michael Friis) #3

@stevenmfreeman is this the example you’re following? https://docs.docker.com/compose/wordpress/


(Steve Freeman) #4

Yes that is the example I followed. Only difference is that I have a
Windows host and the files are on E: which should not make a whit of
difference.


(Rolf Neugebauer) #5

@stevenmfreeman on Windows you need to explicitly share the drives you want to make accessible for container volume sharing. In Beta7 (released Thursday) you should now be able to share the E driver in the settings menu.

The wordpress example should then work. It’s actually part of our standard regression test suite


(Steve Freeman) #6

I shared my E: drive and I still get “Directory /code/wordpress does not
exist”

Is there anywhere I can set/see logging so I can tell why? The existing log says that E: is shared with MobyLinuxVM as /e,/E but still no access. What gives?

Steve Freeman