Docker Community Forums

Share and learn in the Docker community.

17.12 dropping external connections

docker

(Mlair) #1

Docker for Mac
docker

We use docker to run a webapp that connects to an external MS Sql Server database. (Changing to use a SQL docker image is not an option atm.) All of our devs who updated to 17.12 suffered from near-constant database connection drops. Once we downgraded them back to 17.09 (and also tried running outside docker, just fine), things went back to normal and the connections worked fine. Anyone else suffering from a similar issue in 17.12?


(Txepas) #2

Yep, same issue here with 17.12 and a jboss losing connection to a Oracle DB. Going back to 17.09 solved the problem.


(Ebinmore) #3

We are experiencing a similar issue with our deploys using 17.12. On long running I/O tasks, we encounter an

IOError, closed stream
/usr/local/bundle/gems/net-ssh-4.2.0/lib/net/ssh/buffered_io.rb:102:in `send': closed stream (IOError)

It’s intermittent, so it appears that a timeout was decreased or something (like the new HTTP/HTTPS proxies) is adding more overhead and pushing the requests above the timeout. We are still investigating, but restoring to 17.09, everything works like it should.


(Mattyturner) #4

Noticed the same thing with any queries to a remote Redshift cluster that take more than about 30 seconds. The nearly always end with

SSL SYSCALL error: EOF detected

Even though the query actually completes no the cluster.


(Rolf Neugebauer) #5

Looks like this was the same regression also reported at: https://github.com/docker/for-mac/issues/2442

Should be fixed in the next update.