Docker Community Forums

Share and learn in the Docker community.

192.168.65.1:3128: connect: no route to host

OK so I have seen quite a few older posts but after uninstalling and reinstalling, changing resolv.conf, hosts and config.json I still get the same message:

failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: failed to create LLB definition: failed to do request: Head https://registry-1.docker.io/v2/opendronemap/webodm_db/manifests/latest: proxyconnect tcp: dial tcp 192.168.65.1:3128: connect: no route to host

It seems to relate to the issue that also appears when running docker login :
Error response from daemon: Get https://registry-1.docker.io/v2/: proxyconnect tcp: dial tcp 192.168.65.1:3128: connect: no route to host

The same happens with docker compose up (wexodm), hello world and the tutorial

OSX Big Sur 11.2.3
Latest Docker (20.10.6)
Intel Mac

same for the last 2 days suddenly…

Getting the same thing, driving me insane.

macOS 11.3.1
docker desktop 3.3.3 (64133)
engine: 20.10.6

tried changing my docker network subnet (since it appears 192.168.65.1 is in that network) but changing it did not resolve the issue, it still tries to hit 192.168.65.1… also worth mentioning, 192.168.65.1 is in my local network’s address space, so maybe this has something to do with a conflict with the route table?

also tried doing all the noProxy stuff, switching things on or off in the config… nothing has any effect, and this is preventing me from authing to AWS ECR.

The same for me after the last update

ERROR: Get https://registry-1.docker.io/v2/: proxyconnect tcp: dial tcp 192.168.65.1:3128: connect: no route to host

Do somebody have any ideas? I can’t pull any images.

MacBook Pro M1
MAC OS Big Sur 11.3
Docker Desktop 3.3.3, engine 20.10.6

They say trying the same thing again and again… it worked
My guess is that some older module/driver/system extension on the mac messes things up after the latest big sur update.

In hope it might help someone, I did the following restarting between tries:

I installed the latest version of Tunnelblick which I had not used in a long time but guessed it may have left debris in the system. Also, in tunnelblick menu VPN Details → Utilities (tab) → Install tun and tap system extensions. Since VPNs were blamed.

I did these steps selecting “apply and restart” after each and every one of them.

  • Changed the default DNS on my router from 1.1.1.1 to 8.8.8.8 and 1.1.1.1 is now secondary.
  • changed the proxies to manual and set them at 127.0.0.1:3128
  • changed the proxies to http.docker.internal:3128
  • turned manual proxies off

The configuration file on Docker Engine settings is as follows:
{
“dns”: [
“8.8.8.8”,
“8.8.4.4”
],
“features”: {
“buildkit”: false
},
“builder”: {
“gc”: {
“enabled”: true,
“defaultKeepStorage”: “20GB”
}
},
“experimental”: false
}

Somewhat “magically” after all that it worked!

1 Like

After a few days of googling I found a solution that works for me - in Docker Preferences go to Experimental Features and uncheck Use new virtualization framework. And make sure record 34.228.211.243 registry-1.docker.io not exists in your /etc/hosts.

1 Like

Thanks but that was my setup when the problem started.

Unfortunately, your decision didn’t work for me :frowning_face: