Docker Community Forums

Share and learn in the Docker community.

64Bit docker engine on a Raspberry Pi (64bit Kernel + 32 Userland)

Just about to finish up my Raspberry Pi home server when I run into a bit of trouble with docker image which is only available in a 64bit version. Even while the RPI kernel is running in 64bit mode, because of the 32bit Userland, a apt repository install wants to install the 32bit docker engine. I tried switching to docker’s 64bit repository, but then there are other package dependency issues

Not looking forward to reinstalling everything from scratch with a full 64bit OS, I was wondering if it would be possible to manual install the 64bit docker engine version from a deb file instead?

I would image the docker-cli may still need to be 32bit to execute at command line, while the docker engine can be 64bit because it runs in its own memory space closer to the kernel. However I don’t know enough about all the docker components and will need a little advise.