Docker Community Forums

Share and learn in the Docker community.

Ability to run Kuberbetes


(Pmccarroncomcast) #1

Expected behavior

Expected to be able to access kubernetes API container when running the following command.
export K8S_VERSION=$(curl -sS https://storage.googleapis.com/kubernetes-release/release/stable.txt)

docker run
–name master
–volume=/:/rootfs:ro
–volume=/sys:/sys:ro
–volume=/dev:/dev
–volume=/var/lib/docker/:/var/lib/docker:rw
–volume=/var/lib/kubelet/:/var/lib/kubelet:rw
–volume=/var/run:/var/run:rw
–volume=$PWD/manifests:/etc/injected-kube-config:rw
–net=host
–pid=host
–privileged=true
-d gcr.io/google_containers/hyperkube-amd64:${K8S_VERSION}
/hyperkube kubelet
–containerized
–hostname-override=“127.0.0.1”
–address=“0.0.0.0”
–api-servers=http://localhost:8080
–config=/etc/injected-kube-config

Actual behavior

No access to localhost:8080
looks like “-net=host” is not working

Information

  • the output of:
    • pinata diagnose -u on OSX
      OS X: version 10.11.4 (build: 15E65)
      Docker.app: version v1.11.1-beta11
      Running diagnostic tests:
      [OK] docker-cli
      [OK] Moby booted
      [OK] driver.amd64-linux
      [OK] vmnetd
      [OK] osxfs
      [OK] db
      [OK] slirp
      [OK] menubar
      [OK] environment
      [OK] Docker
      [OK] VT-x
      Error exec: echo “00000003.0000f3a6” | nc -U /var/tmp/com.docker.vsock/connect > /tmp/20160510-143037/diagnostics.tar: exit 1
      Docker logs are being collected into /tmp/20160510-143037.tar.gz
      Most specific failure is: No error was detected
      Your unique id is: A202DB7F-35FE-45BB-B5BC-36134C42B1BB
      Please quote this in all correspondence

Steps to reproduce the behavior

  1. Run the command able to start the sublet container
  2. Wait for all containers to setup and start.
  3. curl http://localhost:8080

(Jorge Luis Middleton) #2

Have you tried Kube-Solo or Kube-Cluster? You can get Kubernetes up and running in few minutes without worry about extra configuration.

I highly recommend them.

Jorge


(Pmccarroncomcast) #3

Jorge,

Thanks so much for the response. I just tried Kube-Cluster.
I took me about 6 tries to actually get it running, but it is exactly what we needed – thanks so much!!

—Patrick