Docker Community Forums

Share and learn in the Docker community.

'Access Denied' using Server Manager to Manage a Container

I’m running Windows 2016.

I’m using the container ‘microsoft/iis’ for my little learning experience, which I launch as follows:

docker run -d --name festus --hostname festus microsoft/iis

It works. For example, I can successfully ‘ping festus’. I can also use Internet Explorer on the host to view the sample web site on the container using ‘http://festus:80

The next thing I’d like to do is manage the container using some remote UI tools like Server Manager. So I fire up Server Manager and try to add ‘festus’ as a server. Server Manager sees my container but I’m plagued with Access Denied errors.

What I’ve done so far.

Make sure ‘festus’ is a trusted host: (from host) Set-Item -Path WSMan:\localhost\Client\TrustedHosts -Value “festus”

Made sure the firewall is off: (from container PS) netsh advfirewall set allprofiles state off

It was already off.

Make sure the container’s Administrator account has a valid password: (from container PS) net user Administrator somePassword

When Server Manager tries to browse the container, the error message is:

“Configuration refresh failed with the following error: The metadata failed to be retrieved from the server, due to the following error: Access is denied.”

I’ve also tried using the “Manage As…” option from Server Manager which allows me to type in my password. Same error. I’m typing username as “…\Administrator” but I also get the same error with “Festus\Administrator” and “Workgroup\Administrator”

I can’t figure it out. What am I missing?