Docker Community Forums

Share and learn in the Docker community.

Adding Docker-CE Repo to CentOS - peer's certificate has an invalid signature

docker

(Justinbleach) #1

Doesn’t seem to be a Docker Linux area so putting this here.

When I try and issue: sudo yum-config-manager
–add-repo
https://download.docker.com/linux/centos/docker-ce.repo

I get this message: Could not fetch/save url https://download.docker.com/linux/centos/docker-ce.repo to file /etc/yum.repos.d/docker-ce.repo: [Errno 14] curl#60 - “Peer’s certificate has an invalid signature.”

Anyone else not able to add the docker repository?


(Damianiw) #2

Hi experiencing the same issue did you find a resolution ?


(Justinbleach) #3

I did but it was specific to my RHEL 7 setup I think. I’ll tell you what it is in case it helps you.

I needed to add a reference to my SSL certificate in the yum config. Steps I took where:

sudo vi /etc/yum.conf

At the bottom of the file I added:
sslcacert=/etc/pki/ca-trust/some/location/to/cert/cert.pem


(Vallard Benincosa) #4

Check that your date on your machine is correct. I had this problem when one of my servers was showing a time of August 12, 2010! By fixing the time, the SSL stuff worked fine.


(Aravind32) #5

I am facing the same issue on centos 7 machine. I tried all the above mentioned solutions in vain. Is there a verified solution for this?


#6

Same issue faced here.Im getting

[x yum.repos.d]$ sudo yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo
Loaded plugins: fastestmirror
adding repo from: https:download.docker.com/linux/centos/docker-ce[dot]repo
grabbing file https:download.docker.com/linux/centos/docker-ce[dot]repo to /etc/yum.repos.d/docker-ce[dot]repo
Could not fetch/save url https:download.docker.com/linux/centos/docker-ce[dot]repo to file /etc/yum.repos.d/docker-ce.repo: [Errno 14] curl#35 - “Peer received a valid certificate, but access was denied.”


(Gary Forghetti) #7

I would try to install Docker CE with this command curl --silent -SL https://get.docker.com/ | sh


#8

Adding proxy inside yum.conf solved this issue