Docker Community Forums

Share and learn in the Docker community.

Adding user to docker group have no effect!


(Ncheltsov) #1

I know that this might seem a common one, but I was not able to find a solution anywehere on the web:

OS: Linux 3.14-1-amd64 #1 SMP Debian 3.14.7-1 (2014-06-16) x86_64 GNU/Linux
docker version: $ sudo docker version
Client version: 1.6.2
Client API version: 1.18
Go version (client): go1.3.3
Git commit (client): 7c8fca2
OS/Arch (client): linux/amd64

docer running:
Loaded: loaded (/lib/systemd/system/docker.service; enabled)
Active: active (running) since Mon 2015-07-06 17:48:32 EEST; 23h ago
Docs: http://docs.docker.com
Main PID: 3261 (docker)
CGroup: name=systemd:/system/docker.service
└─3261 /usr/bin/docker -d -H fd://

user: nikolay
user added to docker group: docker:x:127:nikolay
docker restarted: sudo service docker restart
OS restarted
apparmor installed:

Still can not run docker with user nikolay
docker images
FATA[0000] Get http:///var/run/docker.sock/v1.18/images/json: dial unix /var/run/docker.sock: no such file or directory. Are you trying to connect to a TLS-enabled daemon without TLS?

And the most stupid think is that it worked for my user for several hours and then stoped again and nobody knows why!

Any ideas?


(Sabin Basyal) #2

Did you try sudo docker images?
If that’s not the case, can you please check if Docker Daemon is actually running? Try sudo service docker status and see if it is running?


(Sven Dowideit) #3

you also need to log out and log back in again to make that shell process
aware that the user has changed groups.

Sven

Docker Engineer
Ask me anything …
Brisbane, Australia (UTC+10)


(Ncheltsov) #4

yes I tries this

sudo docker images

it works
I need to grant permissions to a concrete user and I can not!
We think that it is something connected to apparmor application, but don’t understand how.


(Ncheltsov) #5

I restarted the whole OS, and still the same problem.