Although Docker is running, daemon cannot be connected

System: Ubuntu 20.02:

Whe I run systemctl status docker, I got:

● docker.service - Docker Application Container Engine
     Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-10-20 14:52:17 JST; 26s ago
TriggeredBy: ● docker.socket
   Main PID: 811329 (dockerd)
      Tasks: 40
     Memory: 26.7M
     CGroup: /system.slice/docker.service
             └─811329 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock

but when I run docker container list, I got:

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

What is the matter?

Part of the installation instructions is a link to Post-installation steps for Linux | Docker Documentation.
You should have seen it while following the installation instructions.

thx but Helpless. Posted this before trying more than 20 solutions.

I am pretty sure the solution is on the page that @meyay shared. If you disagree, please, share what you have tried.

I am not sure what you mean by that. I gues you wanted to say that you tried more than 20 solutions before you created this topic. When you try some solutions it is important to share what you have already tried. Otherwise people can spend hours on helping you, sharing ideas even though you have tried all of them.

The unix socket of docker is usually /var/run/docker.sock. If it is owned by root and the group of it is “docker”, you can use the docker client only if you are the root user or in the “docker” group. Setting the group is the first on the previously suggested page. If you don’t want to do that and you are in the “sudo” group, you can use

sudo docker container list