Automated build: works well , same git build made on computer can't run

Until now I’m used Docker Hub’s automated builder with success. After stacking (in portainer) the package worked as it needed to work.


Today I started to build the same packege on my computer (Windows, Docker desktop with WSL2) , using the usual “docker build -t name/name:latest” command.

After finish, the result was approx the same size as the automated built. (just a few Kb. diff).

I Pushed it to my directory.

After stacking the package (in portainer) with my well known, previously finetuned stack command the container didn’t start properly.

The log showed:
“env: can’t execute 'bash ': No such file or directory”

(I didn’t change my Dockerfile - it contains the run apk add --update bash command, but even if I change it to run apk -add --no-cache bash, it still not working and showing the same error code).

When did I maka a mistake???
I spent the past few hours to investigate the issue, but couldn’t find anything…

Please provide all details required to reproduce the situation.

Given your description, the outcome should be identical regardless where you build your image. At least as long as the environments use the same cpu architecture and therefore use the exact same base image.