Docker Community Forums

Share and learn in the Docker community.

Beta 18 instability

beta

(Webrat) #1

Expected behavior

docker-compose up just works.

Actual behavior

I’m now getting jack is incompatible with use of CloseNotifier in same ServeHTTP call on every single container and all my logging within the container is now gone.

Information

B2E7727F-E037-49AB-899F-0523D3DB7F42 is the diagnostic id.

Docker for Mac: version: mac-v1.12.0-beta18
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160705-163604.tar.gz
[OK] docker-cli
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

Steps to reproduce the behavior

Just upgrade to beta 18 and run docker-compose up


Docker 1.12.0-rc3-beta18: Logging doesn't work when using docker-compose up
(Dustincurrie) #2

I experienced the same after upgrading from beta 17 to beta 18. Uninstalling and re-installing Docker for mac resolved the issue.


(Webrat) #3

Thanks for the hint.


(Mrfitzgerald) #4

I am also having the same issue on Windows.

I have not tried uninstalling/reinstalling yet.

diagnostic: CCC2874B-657A-4D94-B729-646744410A4E/2016-07-06_09-44-00


(Favicon) #5

I’m seeing the same on Docker for Mac. Not yet reinstalled.

Diagnostic: F983F605-49FD-49C8-BC39-EC9D2E3ABF2A


(Ldgarcia) #6

Did re-installing work for you also?


(Psoaresgqls) #7

Didn’t work for me… Is there a specific uninstall procedure I should follow or is Drag&Drop to trash ok ?


(Ldgarcia) #8

I reinstalled (uninstall first and then install the new version) and it solved the issue.