Bind mount on USB Drive - Unmounting and remounting

Hey guys, i’m running docker on my Raspberry Pi. Because i don’t have much space available in my SD card i use a external drive as storage, so if i run an image, let’s say plex, that need to have access to my external drive i’d need to use a bind mount. So assuming that my external drive has been mounted in /data

docker create --name=plex -v /data/movies:/movies linuxserver/plex

That works fine. If i disconnect my external drive and try to read/write in /movies inside the container there’s a “input/output error” which is totally understandable, the problem is that if i reconnect(and remount) the external drive, the container still throws the same error. If i restart the container then the bind mount works fine again.

The external drive is automatically mounted by its UID on /etc/fstab.

I tried using a volume instead of a bind mount, making a symbolic link from /var/lib/docker/volumes/data to /data and then creating the volume but i get the same result.

Anyone knows why this happens? it’s not a big deal to restart the containers but i don’t understand why this happens.