Docker Community Forums

Share and learn in the Docker community.

Bugzilla with docker fails after opening the browser


(Qebetty) #1

I’ve been building Bugzilla with docker using this link:
https://registry.hub.docker.com/u/dklawren/docker-bugzilla/

I can connect through ssh bugzilla@localhost -p2222 but when I open the browser http://localhost:8080/bugzilla the error 500 (Internal Server Error) displays. Do someone have an idea to resolve that? or there is another way to build Bugzilla on Docker???


(Sam Saffron) #2

There must be logs somewhere, start there.


(Qebetty) #3

I’ve run checksetup.pl file and I figure out that mysql is not running after fixing it, I was able to open the Bugzilla URL but when I’ve re-run checksetup.pl, it didn’t ask for email and password for Bugzilla’s admin user, I tried to use --make-admin and --reset-password and this errror display:

“There is no user named ‘Password’. Either you mis-typed the name or that user has not yet registered for a Bugzilla account.”

Therefore couldn’t login to Bugzilla URL, by the way, log doesn’t display some error that can help me to figure out what is wrong. Does someone have any idea what is happening here or what configuration is missing?

I’ll appreciate your comment about it, thanks.


(Sam Saffron) #4

I can’t really help you easily debug this, but if you get nsenter working you can log in to your running instance and snoop around, it makes troubleshooting way easier.


(Sven Dowideit) #5

@sam - that images has ssh running in it - so nsenter is quite pointless.

@qebetty - I’m downloading it now to see if i can poke around. have you considered asking the author of the image? They’d be the expert in its use - The hub links you to their GitHub repository too: https://github.com/dklawren/docker-bugzilla


(Qebetty) #6

@Sven, I’ve asked to author of the image but I don’t have an answer yet. Did you see something when you downloaded the image?


(Sven Dowideit) #7

I’ve just re-downloaded the image from the hub, and then followed the instructions to run:

docker run -d -t \
    --name bugzilla \
    --hostname bugzilla \
    --publish 8080:80 \
    --publish 2222:22 \
    dklawren/docker-bugzilla

and it worked first time. (no 500 error)

Mind you, I don’t know much about bugzilla, and while https://github.com/dklawren/docker-bugzilla/blob/master/checksetup_answers.txt suggests some answers, this image doesn’t set up Sendmail either - so you can’t create new accounts either.


(Qebetty) #8

I’ve reviewed the Database in order to figure out the admin user and I’ve changed the password (sudo ./checksetup.pl --reset-password=admin@example.com) so now I can log in with Bugzilla’s admin user.
Thank you so much for your help.