Can login to docker hub but can not ping or run hello world

Okay I am moderately familiar with dockers and networking and have installed and used dockers and k8s multiple times, but there is something very tricky going on here.

I am able to go to and login no problems. but I can not ping the same address!!!
please tell me how this is possible?

I am not able to run “sudo docker run hello-world” or docker login as i get the same error message

user1@SNDPC7:~$ sudo docker run hello-world
Unable to find image 'hello-world:latest' locally
docker: Error response from daemon: Get net/http: requestcanceled while waiting for connection (Client.Timeout exceeded while awaiting headers).
See 'docker run --help'.

I am on an open internet connection with no proxies or firewalls. running ubunutu 18.04.3 desktop.

This is a clean install and I have followed the directions on and no luck.

user1@SNDPC7:~$ ping
PING ( 56(84) bytes of data.

--- ping statistics ---
298 packets transmitted, 0 received, 100% packet loss, time 304127ms

user1@SNDPC7:~$ sudo docker version
Client: Docker Engine - Community
Version: 19.03.5
API version: 1.40
Go version: go1.12.12
Git commit: 633a0ea838
Built: Wed Nov 13 07:29:52 2019
OS/Arch: linux/amd64
Experimental: false

Server: Docker Engine - Community
Version: 19.03.5
API version: 1.40 (minimum version 1.12)
Go version: go1.12.12
Git commit: 633a0ea838
Built: Wed Nov 13 07:28:22 2019
OS/Arch: linux/amd64
Experimental: false
Version: 1.2.10
GitCommit: b34a5c8af56e510852c35414db4c1f4fa6172339
Version: 1.0.0-rc8+dev
GitCommit: 3e425f80a8c931f88e6d94a8c831b9d5aa481657
Version: 0.18.0
GitCommit: fec3683

Okay i did nothing different tried 1 day later and it worked fine…

Please can someone tell me what the hell happened.

Ping are blocked on that domain, not only for you, but for everyone and always.
Sometimes the docker hub is having issues. A few months back, I wasnt able to push a 300M image for a few days and then one day it worked.
Your issue sound just as that.

To work-around that kind of problem, for production use I recommand running your own registry and copy there all the images you need.

my coworker is able to ping from the same connection. which is super weird. So it was working all day today and then just stopped all of a sudden and now I cant pull down any images.

changed proxy settings to auto and added to dns and rebooted and its working. but i dont know if it was me that fixed it or if it was the DNS gods somewhere else