Docker Community Forums

Share and learn in the Docker community.

Can not build Docker Image with newer Kernel

Hi.
I can’t pull with moby and with “docker pull” natively the sources from docker/desktop-host-tools.
It says that i can’t access them.
I tried it with “docker login && docker pull docker/desktop-host-tools:current” but i didn’t work.
Have you a hint for me?

I work with Windows 10, Docker for Windows, Go, Moby, Git, Linuxkit and tried the tut https://tippexs.github.io/docker/tutorial/2017/05/19/docker-mlkit-windows-setup.html .
I want to build a new docker host image with newer kernel due to some issues i’ll have on other machines.
For this reason i took the linuxkit.yml from the docker-for-win.iso as a template.

Example:

C:\docker-desktop>docker login
Authenticating with existing credentials…
Login Succeeded

C:\docker-desktop>moby build -format tar linuxkit.yml
Extract kernel image: linuxkit/kernel:4.19.20
Add init containers:
Process init image: linuxkit/init:3f1e5c32d6ca9e83a7ea7ad9854da2032971a83f
Process init image: linuxkit/runc:v0.5
Process init image: linuxkit/containerd:v0.5
Process init image: linuxkit/ca-certificates:v0.5
Process init image: linuxkit/getty:v0.5
Process init image: linuxkit/memlogd:ba4fcf55c35a3833546a1e39125bf0fa940327b0
Process init image: docker/desktop-host-tools:current
Pull image: docker/desktop-host-tools:current
�[31mFATA�[0m[0005] Failed to build init tarball from docker/desktop-host-tools:current: Could not pull image docker/desktop-host-tools:current: Error response from daemon: pull access denied for docker/desktop-host-tools, repository does not exist or may require ‘docker login’