Docker Community Forums

Share and learn in the Docker community.

Can not link aws account to docker cloud


(Xazoola) #1

I am trying to follow the example

When i enter the ARN on the Amazon Web Services section of docker cloud, I get this error

“Invalid AWS role or insufficient permissions”

The aws account is well established and have used it for years. I use aws cli and no problems.
I can list the Role just fine with awsCli
colmac@xazoola:~ $ aws iam list-roles|grep colin
"RoleName": “dockercloud-colin-swarm-policy”,
“Arn”: “arn:aws:iam::123456789:role/dockercloud-colin-swarm-policy”

I have “masked” my account id above but it returned all just fine.

When i created the Role i used the correct Docker Cloud External ID. I can login to Docker Cloud using that ID was well.

Anyone have suggestions to find what the problem is?
Thanks,
Colin


(Numatech) #2

Looks like there’s a lot of these requests in the forums lately, I’ve never had that problem before but now I just can’t link my AWS account because of this issue as well… Really annoying. Is it just buggy?


(Xazoola) #3

yep, still not found a solution. it is pretty useless unless this can be resolved.


(Numatech) #4

Tried to contact the support about it, no answer so far…


(Rn3r1) #5

Hey, I have the same error. I just solved it by completing the registration process to Amazon Web Services. You can know if you have completed the registration if you can acces the EC2 service from the services tab in AWS dashboard.


(Xazoola) #6

sadly we have been with aws for many years.