Docker Community Forums

Share and learn in the Docker community.

Can not pull any images for window container mode


(Js34lee) #1

Issue type: when attempting to pull any microsoft base os image it attempts to download but fails with the following error
Using default tag: latest
latest: Pulling from microsoft/dotnet
bce2fbc256ea: Extracting [==================================================>] 252.7MB/252.7MB
b0b5e40cb939: Download complete
d13fff5d417b: Download complete
cb2173f96015: Download complete
02036e6362b4: Download complete
7d50d100495f: Download complete
8cf343cf0f94: Download complete
9fdf7d60f983: Download complete
a791d6c448f4: Download complete
3d5c8856ab68: Download complete
failed to register layer: re-exec error: exit status 1: output: ProcessBaseLayer C:\ProgramData\Docker\windowsfilter\a5a200ada3041a87116e26ac689ecc67f85431c18122719a64620f071fb25726: The parameter is incorrect.

OS Version/build
Type:Windows 10 pro
OS Version: 1607
OS build: 14393.1770

App version
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 17.09.0-ce
Storage Driver: windowsfilter
Windows:
Logging Driver: json-file
Plugins:
Volume: local
Network: ics l2bridge l2tunnel nat null overlay transparent
Log: awslogs etwlogs fluentd json-file logentries splunk syslog
Swarm: inactive
Default Isolation: hyperv
Kernel Version: 10.0 14393 (14393.1770.amd64fre.rs1_release.170917-1700)
Operating System: Windows 10 Pro
OSType: windows
Architecture: x86_64
CPUs: 4
Total Memory: 7.91GiB
Name: SHLEE
ID: J7MM:4YRV:E6OG:Z5NE:JXPK:KLBM:LNVS:G4EY:H34L:OVRP:RUQU:HEJI
Docker Root Dir: C:\ProgramData\Docker
Debug Mode (client): false
Debug Mode (server): true
File Descriptors: -1
Goroutines: 22
System Time: 2017-10-26T11:12:33.7859854+09:00
EventsListeners: 0
Registry: https://index.docker.io/v1/
Experimental: true
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false
Steps to reproduce
-download docker for windows on the official site (stable channel)
-switch to window containers
-execute the following command from windows power shell
docker pull microsoft/nanoserver
note that the same error message pops up when attempting to pull other images from
the public registery such as microsoft/dotner or microsoft/windowservercore etc.
what I have tried
chekced the version of windows os to ensure it is the lates build
uninstalled docker and reinstalled it
manually enabled bitlocker (i don’t know why but someone suggested this method) and tried downloading
checked that docker version is the latest by dowloading from the official site stable channel

I have been stuck for a while and since I am limmited to the number of information relating to this topic I am really lost… it seems to pull perfectly fine in linux containers mode though. Someone please help I am in desperate need for a solution. Thank you!