Can not start a console application in docker

I have an application built on VC++ 2008. (Available for both 32-bit and 64-bit). I can’t get it to run on a windows servercore container.

Following is the description of how the application works on windows host. (not container)

The application has a batch mode and can be started as follows

c:\somefolder\myapplication.exe -b -e inputfile.extn

-b for batch mode.

-e for specifying the input file argument.

When invoked, the application starts in a new console and performs what it is supposed to do the input file.

Following is how the application is setup on the host (where it successfully runs)

  1. Install the vc++2008 redistributable

  2. Copy the application (With all dependencies)

  3. Setup license servers and few environment varialbes

I have done all of the above in container. But no luck. When I run “c:\somefolder\myapplication.exe -b -e inputfile.extn” on the container (I connected to container by doing docker exec -it powershell) nothing happens. No error messages, no output messages. The powershell stays active and receives next commands.

I have tried the following:

  1. Run the application using Start-Process cmdlet. Tried the -NoNewWindow flag.

  2. Checked the application eventlog. (Nothing there)

  3. Checked the docker log file. I find following errors. But I don’t know what to do about them

[10:18:20.725][WindowsDaemon ][Error ] Faulting application name: myapplication.exe, version:, time stamp: 0x562a440c

Faulting module name: ntdll.dll, version: 10.0.17134.799, time stamp: 0x7f828745

Exception code: 0xc0000374

Fault offset: 0x00000000000f479b

Faulting process id: 0x2ecc

Faulting application start time: 0x01d5c7c00dd3f96b

Faulting application path:

Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll

Report Id: 695a1413-71d1-43cd-8dab-046a8968a73f

Faulting package full name:

Faulting package-relative application ID:

I will greatly appreciate any help from the community.