Can we update CUDA version 9.0 to 10.0 in docker container?

I am new to docker. I am trying to run one github repository in docker container. I have few questions regarding the same.

  1. The docker image was created using CUDA version 9.0. I have Tesla T4 GPU and Driver version 470.129.06 in my amazon EC2 instance. I want to update CUDA version from 9 to 10.0. Is is possible to update cuda version inside the docker container? If yes, then How do we update it? Can you share some useful links?
  2. Whenever I run nvidia-docker run command it enters into fish interactive shell. I want it to start bash interactive shell. I don’t know how to enter in bash shell after running docker

The command I am running is:

nvidia-docker run -it --rm -v /Path_to_dataset:/root/data -v $Path_to_model:/root/model --ipc=host scrin/second-pytorch

I tried adding bash in command but does not work (I get error: open: No such file or directory )

nvidia-docker run -it --rm -v /Path_to_dataset:/root/data -v $Path_to_model:/root/model --ipc=host scrin/second-pytorch bash

If anyone can help me. Thank you in advance.