Docker Community Forums

Share and learn in the Docker community.

Cannot connect to the Docker daemon. Is the docker daemon running on this host?

Tried below steps & got success to clear the error.

service docker stop
apt-get update -y
upgrade docker as well,
service docker start
docker node list
docker swarm leave --force
— join docker swarm-token again

I’m kinda noob, so I was stuck on this like 3 days, I want you to know someone on Ecuador loves you! <3 XD

Awesome…i had trouble in starting the docker deamon
Error startng the service, with the default port
docker.service: Main process exited, code=exited, status=1/FAILURE
: Failed to start Docker Application Container Engine.
docker.service: Unit entered failed state.
: docker.service: Failed with result ‘exit-code’.
docker.service: Service hold-off time over, scheduling restart.
: Stopped Docker Application Container Engine.
docker.service: Start request repeated too quickly.
Failed to start Docker Application Container Engine.
systemctl status docker.service journalctl -xe

changes as above to fix it with additional run on
systemctl start docker.service

I had to recreate the docker group first before I could add myself to it.
sudo groupadd docker
sudo usermod -aG docker $(whoami)

thanks, but i still do not understand, instead of docker, sudo docker can work properly

thanks @onezoomin This worked for me :slight_smile:

If you are running centOS or RHEL.
systemctl enable docker <-- adds docker service to start automatically with reboot.
systemctl start docker or service docker start <-- to start it manually